[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] DOH! NT's fixboot killed PV

	Through my own carelessness  - my helper ended up running w2k's
fixboot program on my rootvg's primary PV.  It wrote FAT info of some sort
to the header area of my /dev/hda1 partition.

I am (desperately) hoping that there is some way to recover this header
info. (And that ppl on this list can aide me.)

I thought perhaps the way to go about it was to do a vgcfgrestore ..
however I had no luck - when i ran it w/ the -l / -l -l flags - it would
show me the correct info - but if i ran it w/out the -l flags - then it
would give me the following error:

ERROR "pv_read(): PV identifier invalid" reading physical volumes

I get the same error if I try to do pvscan.

pvdata shows that things are FUBAR - w/ a UUID of something like "0
NAME-     -FAT1-2   - <GARBAGE>" - but I know the proper identifier is in
the cfg backup file - since it can be displayed and is

If anyone could provide tips / directions on how to go about fixing this
problem - I would be very greatful - I just finally got the system
built/installed to my satisfaction and would hate to start over.

-john marquart

ps.  Bill & Ted rule!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]