[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [linux-lvm] Problem mit lvm nach dem Reboot.



I agree with his recomendations. It sounds like an issue I had a while back
and that fixed it for me as well.

-- 
Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-796-9023
email: austin coremetrics com 

> -----Original Message-----
> From: Ulrich Wiederhold [mailto:U Wiederhold gmx net]
> Sent: Thursday, November 08, 2001 4:30 PM
> To: Heinz Mauelshagen
> Subject: Re: [linux-lvm] Problem mit lvm nach dem Reboot.
> 
> 
> Hallo,
> zwei Dinge.
> 1. Upgrade auf 1.0.1-rc4
> 2. Wahrscheinlich mußt Du uuid_fixer auf alle pv´s anwenden.
> 3. Das letzte Backup zurückspielen
> 
> Gruß
> Uli
> 
> * CC. Spindler <ccspindler prs-gmbh de> [011108 13:50]:
> > Eine verregneten Gruß aus Karlsruhe!
> > 
> > Hallo Herr Mauelshagen
> > 
> >  Ich habe  ein für  mich größeres  Problem mit lvm.   Ich 
> habe  aus 10
> > Platten  nach un  nach ein  logisches Volume  gebildet. 
> Dann  habe ich
> > versucht mit  pvmove zwei  Platten zu verschieben  und mit  
> vgsplit zu
> > entfernen.   Leider hat  es aber  nicht geklappt.   Dann 
> habe  ich mit
> > pvchange die beiden Platten  deaktiviert und konnte mit 
> resize2fs etc.
> > die Größe  anpassen. Und  die Daten waren  bis auf wenige  
> Fehler noch
> > vorhanden. 
> > 
> >   Nach dem  ich nun  einen Reboot durch  geführt habe, geht 
>  nix mehr.
> > vgchange meint, daß es keine VGs finden kann. Und vgscan ergibt
> > folgende Ausgabe:
> > 
> > 
> ----------------------------------------------------------------------
> > host:/etc# vgscan 
> > vgscan
> > vgscan -- reading all physical volumes (this may take a while...)
> > vgscan -- found inactive volume group "pool"
> > vgscan -- only found 12353 of 12675 LEs for LV /dev/pool/pool_lv (0)
> > vgscan -- ERROR "vg_read_with_pv_and_lv(): allocated LE of 
> LV" can't get data of volume group "pool" from physical volume(s)
> > vgscan -- ERROR "vg_read_with_pv_and_lv(): allocated LE of 
> LV" creating "/etc/lvmtab" and "/etc/lvmtab.d"
> > 
> ----------------------------------------------------------------------
> > 
> > Ich benutze: 
> > 
> >   - den 2.4.9 Kernel mit lvm version 0.9.1_beta2
> >   - Debian testing
> >   - und die Debian packete von ihrem ftp-Server:
> >        
> >        liblvm-iop10_0.9.1.beta7-1_i386.deb
> >        lvm-base_1.1-1_i386.deb
> >        lvm-iop10_0.9.1.beta7-1_i386.deb
> > 
> > 
> > Wenn  sie mir  irgendwie weiter  helfen können,  wie ich  
> die Daten/LV
> > wieder  bekommen kann, wenn  auch nur  in Teilen,  dann 
> wäre  ich sehr
> > dankbar. Vielleicht  können sie mir auch  genau sagen, wie  
> ich das LV
> > splitten  kann.  Ich  hatte  jedes  mal beim  Aufruf  von 
> pvmove  eine
> > Fehlermeldung  bekommen  (die genaue  Meldung  habe  ich 
> leider  nicht
> > mehr).  Sie lautete  in etwa:  noch 65536  nicht gelesen.  
> Und deshalb
> > funktionierte auch vgsplit nicht.
> > 
> > 
> >   Vielen Dank im voraus für ihre Hilfe.
> > 
> >   CC. Spindler
> > 
>  
> -- 
> 'The box said, 'Requires Windows 95 or better', so i 
> installed Linux - TKK 5
> 
> _______________________________________________
> linux-lvm mailing list
> linux-lvm sistina com
> http://lists.sistina.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://www.sistina.com/lvm/Pages/howto.html
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]