[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Re: linux2.4.10/lvm1.0.1rc3 does not compile



On Tue, Oct 02, 2001 at 01:07:22PM -0700, Aman Shahi wrote:
> 
> so changing __update_hardblocksize(lv_t *lv)
> in ~/LVM/1.0.1-rc3/kernel/lvm.c and
> ~linux-2.4.10/drivers/md/lvm.c 
> to  __update_hardsectsize(lv_t *lv)
> should resolve this compilation problem.

Thanks, that did the trick for me. 

After that vgscan did not find any Volume Groups in 2.4.10, while it
did in 2.4.7 (with LVM 1.0). Interesting: using "vgrename" on 2.4.7
helped here at last (After trying lots of other non-destructive changes
to the VG/underlying PVs) . I just renamed the Group vg1 to vg0 and now
vgscan detects it on 2.4.10, too.

This incident leaves a bitter taste somehow...

Regards, Markus



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]