[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] VFS Locking Patch for 2.4.20? 2.4.19 does not work



On Mon, Dec 16 '02 at 14:12, Patrick Caulfield wrote:
> > is there anywhere a VFS locking patch for kernel version 2.4.20? The 
> > latest LVM1-release only includes the one for 2.4.19.
> The 2.4.19 one should work just fine.
As you might know 2.4.20 has a filesystem corruption bug with ext3 fs.
Unforunately the patch changes the semantic of sync_supers by adding a
parameter "wait".
I've not enough knowledge of how the VFS works to dear to update the
patch ... did anyone already do this?

BTW: the ext3 patches are available from
    http://www.zip.com.au/~akpm/linux/patches/2.4/2.4.20/
-- 
Goetz Bock       (c) 2002 as     blacknet.de - Munich - Germany   /"\
IT Consultant    GNU FDL 1.1    secure mobile Linux everNETting   \ /
                                                                   X
 ASCII Ribbon Campaign against HTML email & microsoft attachments / \



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]