[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] vgchange -a y /dev/System fails



On Thu, Jan 31, 2002 at 12:14:17PM +0100, Heinz J . Mauelshagen wrote:
> > -> My BigAssLVMRaid VG is gone :-(
> > 
> > Did I just lose my data?
> 
> If you really tried all your  metadata backups unsuccessfully, I am afraid
> so  :-(  

I tried other ones, but every time, I'm getting:
vgcfgrestore -- VGDA for "BigAssLVMRaid" successfully restored to physical
volume "/dev/rd/disc0/part7"
vgcfgrestore -- you may not have an actual backup of restored volume group
"BigAssLVMRaid"

Am I supposed to give a special flag to vgcfgrestore, or maybe pvcreate?
(I did not use the default physicalextentsize)

As a reminder, I am currently running this command:
FILE=/etc/lvmconf/BigAssLVMRaid.conf.2.old; vgcfgrestore -f $FILE -n BigAssLVMRaid -ll; read a; pvcreate -yff `cat /tmp/partlist`; for pv in `cat /tmp/partlist `; do vgcfgrestore -f $FILE -n BigAssLVMRaid $pv; done; vgscan

Short of all this, can I re-create the VG the same way I did the first
time, and hope to get my filesytem again if I recreate the same LVs?
(like I can do with software raid)

This VG was working fine before I restored the other one (active and all)

> Some users reported snapshot problems with the recent 2.4.x kernels.  They
> are not  100% reliable  due to VM  issues being sorted  out by  the kernel
> community hopefully which will hopefully be integrated in 2.4.18.

Ok. I guess I'll know to steer clear  from snapshots in the meantime, but if
LVM doesn't even allow  me to recover a VG that  hasn't been overwriten with
random data, I don't know how much data I'm willing to trust to it...

Either way, thanks for your help.

Marc
-- 
Microsoft is to operating systems & security ....
                                      .... what McDonalds is to gourmet cooking
  
Home page: http://marc.merlins.org/   |   Finger marc_f merlins org for PGP key



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]