[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Re: LVM Redhat 7.2 : Volume Group not activated on boot



le lun 11-02-2002 à 19:49, linux-lvm-request sistina com a écrit :
> My problem is on boot of the machine I get a  error from the mount 
> process that it can not mount and check my file system
> "/dev/vg01/vg01lv01" and a option to go into singe user mode where I can 
> se that the "vgchange -a y" is not run to activate
> the volume group. I have looked at the rc.sysinit and there is this 
> entry that should activate all defined volume groups.
> Have any of you out in cyberspace seen the same problem with Redhat 7.2 ?
> 
> cut from the /etc/rc.d/rc.sysinit :
> 
> # LVM initialization
> if [ -e /proc/lvm -a -x /sbin/vgchange -a -f /etc/lvmtab ]; then
>         action $"Setting up Logical Volume Management:" /sbin/vgscan && 
> /sbin/vgchange -a y
> fi
> 
> My setup :
> 
> HP Omnibook 6000 laptop
> Redhat 7.2
> I have installed the "new" 2.4.17 Linux kernel
> VLM support works (That is I can create lv's and I use ext3 file system 
> on them)
> I have added my lvm to fstab and are able to mount/umount the file 
> system without problems
> 
> cut from fstab :
> 
> /dev/vg01/vg01lv01      /home5/pgram/dev        ext3    defaults        1 2
> 
> -- 
> 
> /regards
> 
> Peter Gram
> 
> Phone : +45 2527 7107
> Fax   : +45 4466 8856
> 
> Miracle A/S
> Kratvej 2
> 2760 Målev
> http://miracleas.dk
> 


I added my own entry in the rc.sysinit file after the root filesystem is
made writable. So, here is my own entry (two lines below # DS ...:

# The root filesystem is now read-write, so we can now log via syslog()
directly..
if [ -n "$IN_INITLOG" ]; then
    IN_INITLOG=
fi

# DS Ok, now scan all volume groups for LVM and activate them
/sbin/vgscan
/sbin/vgchange -a y

if ! grep -iq nomodules /proc/cmdline >/dev/null 2>&1 && [ -f
/proc/ksyms ]; then
    USEMODULES=y
else
    USEMODULES=
fi

It is near line 315 in my rc.sysinit file.

I also have the initrd image made with lvmcreate_initrd and the
appropriate entry in the lilo.conf file. I am using kernel 2.4.17 as
well.

-- 

=======================================
Daniel Savard
Consultation Informatique Daniel Savard
551, boul. Sir-Wilfrid-Laurier
suite 105
Beloeil, (Québec)
Canada J3G 4J1

Tél: (450) 467-8014
Internet: dsavard cids ca
=======================================





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]