[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] bug: raid1 sub-devices are scanned too



Hello, thanks for the reply. 

The problem seems to have disappeared after a reboot, or then I've
tried the vgscan -f -stuff - vgscan now just seemed to work OK. I
could've sworn I tried that vgscan -f before without too much success,
but, all in all, I imagine it's not worth hunting a bug before one can
find an easily repeatible situation.

On Sat, Feb 23, 2002 at 11:55:29AM +0100, Heinz J . Mauelshagen wrote:

> > this is a bug in 1.0.3 with exported VGs.
> > 
> > If you import your VG "mirror" again, you should be fine.
> > Rather than imprting, "vgscan -f" should work as well.

In the original situation vgscan -f was of no help, only the
export/import-trick (and a reboot) allowed me to access the mirror-vg.

> Are /dev/ide/host0/bus1/target1/lun0/part1 and
> /dev/ide/host0/bus0/target1/lun0/part1 really the ones making up /dev/md/1 ?
> 
> Regards,
> Heinz    -- The LVM Guy --

Yes:
md1 : active raid1 ide/host0/bus1/target1/lun0/part1[1] ide/host0/bus0/target1/lun0/part1[0]
      58633216 blocks [2/2] [UU]

-- 
  _____________________________________________________________________
     / __// /__ ____  __                              Erkki Seppälä\   \
    / /_ / // // /\ \/ //ircnet                           Modeemi Ry\  /
   /_/  /_/ \___/ /_/\_\ modeemi fi        http://www.modeemi.fi/~flux/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]