[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] LVM on 2.4.17



On Fri, Jan 18, 2002 at 12:12:54AM +0000, James Pattinson wrote:
> Hi!
> 
> I've been neglecting my systems and LVM... currently trying to upgrade
> from 2.4.16 to 2.4.17. 2.4.17 seems to include LVM 1.0.1-rc4 but it fails
> when I compile:
> 
> lvm-snap.c: In function `lvm_snapshot_COW':
> lvm-snap.c:380: `phys_start' undeclared (first use in this function)
> lvm-snap.c:380: (Each undeclared identifier is reported only once
> lvm-snap.c:380: for each function it appears in.)
> 
> Do I need to apply additional patches?

You shouldn't do, no. I've built several dozen 2.4.17 kernels (no, really!)
without this error.

Check your kernel source is really clean. If you've patched it up from an
earlier one then look out for failures. 2.4.17 builds cleanly either as it
stands or with patches from LVM 1.0.1

patrick




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]