[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Installing LVM on RH v7.3



kevin joubert com wrote:
I am having trouble installing LVM on RH v7.3 (2.4.18-10).

1st question is:
why are you trying to compile by hand an older version of LVM while rh-7.3 ships with lvm-1.0.3 (with a fixed pvmove and small binaries that fit on an initrd btw)?


As I am pretty sure this has been discussed already, please excuse the question, but I can't
figure out how to search the "linux-lvm" archives.


Anyway, I can run "configure" okay:
---------------------------------------
[root localhost lvm]# pwd
/usr/local/bin/lvm
[root localhost lvm]# /usr/src/redhat/SOURCES/LVM/1.0.1/configure
....
In file included from /usr/src/redhat/SOURCES/LVM/1.0.1/tools/lib/liblvm.h:53,
                 from /usr/src/redhat/SOURCES/LVM/1.0.1/tools/lib/basename.c:34:
/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace

edit the file /usr/src/redhat/SOURCES/LVM/1.0.1/tools/lib/liblvm.h go at line 53 remove the line #include <linux/autoconf.h>

L.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]