[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] cannot mount snapshot volumes



On Wed, Sep 25, 2002 at 11:11:04AM +0200, Marien Tielemans - Van Boxtel Software BV wrote:
> Hello Patrick,
> 
> Redhat 7.3 uses kernel 2.4.18-3 .
> I tryed to patch the kernel with : linux-2.4.18-VFS-lock.patch (located in
> LVM/1.0.5/PATCHES )
> 
> In the README it is mentioned that kernels supplied with RedHat , Mandrake
> etc are a little different from the kernels
> supplied bij kernel.org .
> Since the lvm-1.0.5-2.4.18-3custom.patch worked fine with the "RedHat "
> kernel i thought the VFS-lock patch also should work.
> What do you advise me to do ?
>  Thanks,
> 

The LVM patches adapt themselves to the kernel you are patching so should apply
to most kernels without trouble. the VFS lock patch is just a static patch
against the named kernel.

Your options are:

1) build a 2.4.19 kernel from ftp.*.kernel.org
2) apply the VFS lock patch to the redhat kernel and manually fix the rejects
3) lean on redhat to include the patch

patrick




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]