[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [linux-lvm] debian and LVM: Problem with lilo



Stefan Wrote :

>
>Hi all,
>
>I have created a volume group and some logical volumes. The 
>volume group 
>contain all directories, only swap and /boot are physical 
>volumes. At the 
>moment debian is running at the ram disk.

What version of debian are you running ?

>
>The installation steps are ok and I would like to create a bootable at 
>/dev/hda1 (my boot volume). I switched to another virtual 
>console and type 
>the following command
>
>lilo -r /target -F /etc/lilo.conf
>
>After that I get the message that
>
>Fatal: Not a number: "/dev/rootvg/rootlv"

You have to make a special initrd image to be able to run root on
a logical volume.
>
>Has anyone an idea what I can do to create a correct boot table?
>
>Thanks
>
>Stefan


But when you are running debian sarge, don't place your root file system
on a
logical volume.
During boot the volume manager has to be able to create a file and that
is not
possible with sarge because it booting with a cramfs filesystem during
boot
and that filesystem is readonly.

I placed the root file system back on a partition.

Greetz Jan

>-- 
>+++++++++++++++++++++++++++++++++++++++++++
>Dipl.-Ing. (FH) Forstwirtschaft
>Stefan Feeser
>+++++++++++++++++++++++++++++++++++++++++++
>have a look to
>--
>http://www.felino.de
>http://www.lug-untermain.de
>http://www.project-ibex.org


----
With regards Jan H. van Gils
Internet web-page http://www.Knoware.NL/users/janvg/
Internet e-mail address JanVG Knoware NL
RIPE Whois JHG5-RIPE, 6BONE Whois JHG1-6BONE




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]