[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Ext3 -> ReiserFS on '/' convertion prob

Time for me to feel really foolish... I am trying to do just this from '/' but I am getting a "Device or resource busy" error... '/proc' is mounted off of root already... I tried continuing on and it seemed to have worked anyway though it threw a LOT of:

depmod: *** Unresolved symbol in /lib/modules/2.4.22-1.2115.nptl/unsupported/<dir/file>

The rest seemed fine and I made the entry into grub.conf pointing to the new boot image. I ams till getting a kernel panic now but it no longer seems to have anything to do with LVM, simply it is -still- looking for an ext3 partition and obviously failing to find it.

Is there an LV, LVM, VG or PV command I need to issue to tell the system that the filesystem is now resierfs? As I mentioned, I have edited '/etc/fstab', '/etc/mtab' and '/etc/blkid.tab' to reflect the changes. What am I missing? Gah! I feel like I am so close yet so far!


Jord Tanner wrote:
Don't do any symlinking, instead try this:

sh-2.05b# mount -t proc proc /mnt/sysimage/proc
sh-2.05b# chroot /mnt/sysimage /bin/bash
sh-2.05b# source /etc/profile
[root hostname /]# lvmcreate_initrd
[root hostname /]# exit
sh-2.05b# umount /mnt/sysimage/proc
sh-2.05b# shutdown -r now
You may have more success. I think the reason you were getting errors is
that lvmcreate_initrd assumes that your system file tree starts at /,
not at /mnt/sysimage. You were able to fool it somewhat with symlinking,
but the real solution is to chroot to the real /, then run
lvmcreate_initrd. As always YMMV.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]