[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] pvmove problem



I am trying to remove an old harddrive from one of my volumes using:
pvmove -v /dev/hdh3
It was chugging along just find until about half way through when it froze. Linux was not "frozen", but I do not think it would allow any io to the block devices (logins, ls's, etc would stall). I waited about an hour, at which point it was still stuck on the same extent, and had no other option but to hard reboot. When the system was booted, the volume to which hdh3 belonged, would no longer mount:


$ vgscan
vgscan -- reading all physical volumes (this may take a while...)
vgscan -- found active volume group "vol1"
vgscan -- only found 2523 of 768 LEs for LV /dev/vol2/software (1)
vgscan -- ERROR "vg_read_with_pv_and_lv(): allocated LE of LV" can't get data of volume group "vol2" from physical volume(s)
vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
vgscan -- WARNING: This program does not do a VGDA backup of your volume groups



Looks like some lvm metadata has been corrupted. So I ran vgcfgrestore on /dev/hdh3: same result. Then I ran it on all the PVs in vol2: same result. Does anybody have a solution to get this volume mounted? There is a bunch of data on vol2, but not all that much in /dev/hdh3, so a partial restore would be ok.


Thanks,
Skip


_________________________________________________________________
Help STOP SPAM with the new MSN 8 and get 2 months FREE* http://join.msn.com/?page=features/junkmail





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]