[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Disc crash when using LVM...



On Tue, May 27, 2003 at 02:00:17PM +0200, fnt wrote:
> I think there is a vgrestore or sometthing like that
> and then u will have to recreate the volumen
> 
> vgcfgrestore<-- that one is the comand.

Right, and you need to run "pvcreate -ff ..." on the PV you want to vgcfgrestore
to first.

Regards,
Heinz    -- The LVM Guy --

> 
> Best Regads
>   ----- Original Message ----- 
>   From: Kim Krüger-Monsen 
>   To: linux-lvm sistina com 
>   Sent: Thursday, May 22, 2003 5:59 PM
>   Subject: [linux-lvm] Disc crash when using LVM...
> 
> 
>   I'm desperate... please help...
> 
>   First of all I'm rather new to this LVM business, but I managed to get a three disc LVM up and running, but now everything is chaos. One disc just crashed and I can't retrieve any of the information from the 2 remaining discs, please help me retrieve my data. Yes, it was an IBM drive, but it was of a rather new model (80GB) and not much used, so I was rather astonished about the crash.
> 
>   I have read about another guy who also experienced a disc crash (IBM) and he solved it by replacing the faulty drive with another one, but he didn't mention how he managed to get it up and running again. Did he use a replacement drive of the same size? What commands did he have to use in order to get it up and running again?
> 
>   I've been searching for hours to find any relevant information about what to do in order to retrieve the remaining data from my other drives. I'm not good at this so I really don't want to issue any commands that will delete my remaining data permanently.
> 
>   Here's how it looks like now:
> 
>   >pvscan
>   pvscan -- reading all physical volumes (this may take a while...)
>   pvscan -- inactive PV "/dev/hdd1"  is associated to unknown VG "vg01" (run vgscan)
>   pvscan -- inactive PV "/dev/hda8"  is associated to unknown VG "vg01" (run vgscan)
>   pvscan -- total: 2 [139.70 GB] / in use: 2 [139.70 GB] / in no VG: 0 [0]
> 
>   >vgscan
>   vgscan -- reading all physical volumes (this may take a while...)
>   vgscan -- ERROR "vg_read_with_pv_and_lv(): current PV" can't get data of volume group "vg01" from physical volume(s)
>   vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
>   vgscan -- WARNING: This program does not do a VGDA backup of your volume group
> 
>   >lvscan
>   lvscan -- no volume groups found
> 
>   I have no idea what has happened to my volume group, it seems like it has disappeared. All I can do is scan for the physical volumes.
> 
>   What to do next?? I'm still searching for information relevant to the problem, but please give me a hint or two...
> 
>       /Kim
> 

*** Software bugs are stupid.
    Nevertheless it needs not so stupid people to solve them ***

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Heinz Mauelshagen                                 Sistina Software Inc.
Senior Consultant/Developer                       Am Sonnenhang 11
                                                  56242 Marienrachdorf
                                                  Germany
Mauelshagen Sistina com                           +49 2626 141200
                                                       FAX 924446
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]