[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [linux-lvm] Snapshot creating problem



I think I had the command wrong. I was trying:
lvcreate -s -n snaptest -c 1M -L 200G /dev/vg0/data

now, using
lvcreate -s -n snaptest -pr -L 200G vg0/data

It works like a champ!! Thanks. It seems taking some defaults, as well as beginning the origin path at the vg level fixed it. (not sure, really) Anyhow, it works now - and quite fast too! Thanks for a very cool program.

Regards,

--
Christopher Barry
Manager of Information Systems
InfiniCon Systems
http://www.infiniconsys.com

-----Original Message-----
From: Alasdair G Kergon [mailto:agk uk sistina com]
Sent: Monday, March 17, 2003 2:23 PM
To: linux-lvm sistina com
Subject: Re: [linux-lvm] Snapshot creating problem


On Mon, Mar 17, 2003 at 02:00:36PM -0500, Barry, Christopher wrote:
> Mar 17 12:47:16 debian kernel: device-mapper: internal error adding target to table

That's a (known) misleading error message - it's no longer necessarily
an error internal to the kernel, but can be caused by invalid 
parameters being supplied to a device-mapper target.

> To give you more info I need some instructions on how to get you the debug output.
See previous messages on this list, WHATS_NEW file, example.conf, 
lvm.conf man page etc.

e.g. Use a config file containing:

  log {
        file='/tmp/lvm2.log'
        level=7
        overwrite=0
  }

And remember to say exactly which kernel patches you applied.
[The device-mapper version number is not sufficient because 
people have produced patches that don't update it.]

For example, a set of patches before Xmas had a bug that is 
known to stop all snapshots from working.
To see if you have that logic bug, check dm-snapshot.c
a little after line 400 - it should have:
  if (persistent != 'P' && persistent != 'N') {
                        ^^
        ti->error = "Persistent flag is not P or N";

Alasdair
-- 
agk uk sistina com

_______________________________________________
linux-lvm mailing list
linux-lvm sistina com
http://lists.sistina.com/mailman/listinfo/linux-lvm
read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]