[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [linux-lvm] snapshot with bigmem broken



> > I did more testing, and it appears that snapshots in LVM will not
work
> > with either 4GB or or 64GB support enabled in the kernel under
2.4.20.
> > This includes both LVM 1.0.7 or the latest LVM2.
> >
> 
> That's a known issue. You are faced with a VM flaw.
> 
> I presume that it's not LVM snapshots only bacause HIGHMEM is
> basically broken.

Can you give more specifics/examples/web links/etc?  Does this mean I
should avoid LVM completely with HIGHMEM?  What if any other problems
should I expect with LVM (and/or other software)?

> > Is there anyone using LVM snapshots with 64GB RAM support (or even
4GB
> > RAM support, as snapshots would be good for at least our medium
size
> > servers if not our large ones)?  Is so, let me know the kernel
version
> > and LVM version you are using so that I can try it.
> 
> Probably not, because the system lifelocks on bounce buffers (which
is
> the sympton of the principle HIGHMEM bug).
> Obviously not a lot of HIGHMEM users out there raising priorities to
fix
> this.

Is this easy to reproduce?  If so, how?  Sounds like I am either a
lucky early adopter of a >4GB Libux system, and/or the problem is rare
even on HIGHMEM systems?

Thanks.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]