[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Re: once again about 2.6 kernel



Valentine Kouznetsov <vkuznet yahoo com> writes:

> I had a look at lvm mailing list about kernel 2.6
> questions. So far I understood that in order to run
> 2.6 kernel with LVM2 on a system which previously run
> 2.4 kernel with LVM1 you need
> 1) patch 2.4 kernel with device-mapper patch
> 2) use new LVM2 tools (LVM2.2.00.07) which need to be
> installed separetly on the system to allow
> simulteneously use LVM1 and LVM2

LVM2 doesn't require any changes to the disks.  It will understand the
LVM1 metadata.  You don't need to patch your 2.4 kernel to use
device-mapper in 2.6, either.  They can both peacefully coexist, as
long as your boot scripts run the right version of the tools.  A
somewhat ugly solution is to run both version, since only one of them
will do anything anyway.

-- 
Måns Rullgård
mru users sf net




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]