[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] depmod in lvmcreate_initrd erro rmessages with different kernel


I am trying to use lvmcreate_initrd to make an initrd for a kernel different
than the one which is running (to be more precise, I have a running redhat 9
and I am doing lvmcreate_initrd chrooted in a gentoo). Thus I run 
$ lvmcreate_initrd 2.4.24
When lvmcreate_initrd runs depmod, it runs
$ depmod -a 2.4.24
depmod echoes a lot of errors message because there are a lot of unresolved 
symbols (because the running kernel isn't the kernel I run depmod for). The 
exit status is 0, though and the initrd is created.
The right depmod invocation should (if I'm not wrong) be:
$ depmod -a 2.4.24 -F /usr/src/linux-2.4.24/System.map

Is this a problem (depmod having unresolved symbols) ? (there is a comment in 
the lvmcreate_initrd code which seems to imply that it is not a problem, but I 
am not sure)

If yes, I think a new option should be added to lvmcreate_initrd, for the
System.map location.

If no, this should be stated in the man page.

I can do diffs if you want.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]