[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] prob w/ lvm2 on root (RAID 5), creating mkinitrd



I'm having problems creating an mkinitrd image where I want the /
directory to be lvm2.

Setup:
o  Running Debian Sarge using stock 2.6.7-k7-smp w/ udev; per docs, the
Debian initrd-tools support lvm2 on root
o  Volume group named "vg" created from /dev/md1 (which is RAID 5)
o  Logical volume "root" on "vg"
   => result: a lvm2 device called "/dev/vg/root"
o  Mounted /dev/vg/root on /mnt and copied over my current / partition
o  Tried to create an initrd image using /dev/vg/root as / and I get
the following:

portland:~# chroot /mnt mkinitrd -o /boot/initrd.img-2.6.7-1-k7-smp-LVM
/usr/sbin/mkinitrd: neither /dev/fd or /proc/self/fd exists!
Try mounting the proc filesystem: mount -tproc none /proc
portland:~# chroot /mnt mount -tproc none /proc
portland:~# chroot /mnt mkinitrd -o /boot/initrd.img-2.6.7-1-k7-smp-LVM
/usr/sbin/mkinitrd: device /dev/vg/root is not a block device

Using mkinitrd in a chroot environment, instead of with "-r", may be
Debian specific. In any case, I'm stuck now -- any ideas? Help much
appreciated.

Thanks,

Richard

p.s. I know /boot should not be on the lvm2 device; my plan was to move
/boot to it's own partition, /dev/md0 (setup as RAID 1), as soon as I
had the initrd image.


		
__________________________________
Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!
http://promotions.yahoo.com/new_mail

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]