[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] duplicate pv.



Hi, I have a 2.6.9 kernel and I have problems to
create an vg device over a raid1 array.
Look:
sole:/usr/src/linux# cat /proc/mdstat 
Personalities : [raid1] 
md7 : active raid1 sdb2[1] sda2[0]
      244147712 blocks [2/2] [UU]
      
md1 : active raid1 sdb6[0] sda6[1]
      1951744 blocks [2/2] [UU]
      
md2 : active raid1 sdb7[0] sda7[1]
      1951744 blocks [2/2] [UU]
      
md3 : active raid1 sdb8[0] sda8[1]
      979840 blocks [2/2] [UU]
      
md4 : active raid1 sdb9[0] sda9[1]
      9767424 blocks [2/2] [UU]
      
md5 : active raid1 sdb10[0] sda10[1]
      9767424 blocks [2/2] [UU]
      
md6 : active raid1 sdb11[0] sda11[1]
      7815488 blocks [2/2] [UU]
      
md0 : active raid1 sdb5[0] sda5[1]
      96256 blocks [2/2] [UU]
      
unused devices: <none>

sole:/usr/src/linux# pvcreate /dev/md7
  Physical volume "/dev/md7" successfully created

sole:/usr/src/linux# pvdisplay 
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  --- NEW Physical volume ---
  PV Name               /dev/sda2
  VG Name               
  PV Size               232,84 GB
  Allocatable           NO
  PE Size (KByte)       0
  Total PE              0
  Free PE               0
  Allocated PE          0
  PV UUID              
lvryBm-VRK5-xL8Q-mQRm-qnXI-707c-YMc2z1

sole:/usr/src/linux# vgcreate vg00 /dev/md7
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Volume group "vg00" successfully created

sole:/usr/src/linux# lvcreate -L 240000M -n lv00 vg00
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Found duplicate PV lvryBmVRK5xL8QmQRmqnXI707cYMc2z1:
using /dev/sdb2 not /dev/sda2
  Volume group "vg00" doesn't exist
sole:/usr/src/linux# 

thx for any help
Luigi.



		
__________________________________ 
Do you Yahoo!? 
Send a seasonal email greeting and help others. Do good. 
http://celebrity.mail.yahoo.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]