[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Cannot create a Volume Group



Hi,

El mié, 15-12-2004 a las 01:08, Alasdair G Kergon escribió:
> On Wed, Dec 15, 2004 at 12:36:55AM +0100, Fernando Ruza wrote:
> > Everything seems to be create properly, however when now I'm trying to
> > activate the volume group or to scan it, it says it cannot found it:
>  
> > sol:~# vgchange -a y vg1
> >   Unable to find volume group "vg1"
> > sol:~# vgscan
> >  No volume groups found
>  
> >   lvm2           2.00.29-1
> 
> Firstly, there's a bug in pvcreate 2.00.29 (it'll sometimes fail
> with an error message when it shouldn't) - upgrade to .31.

Well, I don't think is the version. I've just upgrade to 2.00.29 before
writing to the list and with the version I had before it happened the
same.

> Use -vvv options to see what's going on and why it ignores things.
> e.g. pvscan --partial -vvv
> 

After doing the pvcreate /dev/hda1 /dev/hda4 /dev/hdb1, pvscan --partial
-vvv   lists me all the devices y /dev and at the end says:

  PV /dev/hda1         lvm2 [7,96 GB]
  PV /dev/hda4         lvm2 [15,48 GB]
  PV /dev/hdb1         lvm2 [3,00 GB]
  Total: 3 [26,44 GB] / in use: 0 [0   ] / in no VG: 3 [26,44 GB]

After doing the vgcreate /dev/vg1 /dev/hda1 /dev/hda4 /dev/hdb1,
vgscan --partial -vvv   lists me all the devices y /dev and at the end
says: No volume groups found

The device /dev/vg1 is not created although vgcreate says Volume group
"vg1" successfully created.


> Alasdair
-- 
Yo uso software libre, ¿Y tu?
¿Qué es el software libre? consulta: http://www.gnu.org/philosophy/free-sw.es.html

Fernando Ruza 
e-mail: feruza terra es
jabber: fruza jabber guadawireless net
web: http://guada24.guadawireless.net
Tlf: 661123845
Linux user: #273644 (http://counter.li.org)
Debian Sid (Kernel 2.4.20 & ext3)

"In an internet without fences ... who needs 'gates'"



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]