[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Can't mount after crash



Hi all,

Not anyone out there having a clue on what to do? It seems that about the same thing has happened to the submitter of https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142737 "Fedora Core 3 system with lvm2 won't boot". Is this acceptable? Because of its impact., this is the kind of bug my company would consider a "show-stopper", and relabel the project "beta" again.

So if there is no way to fix the error, is there any way to recover any of my ~300GB of data? Fourtunately I have backuped all the crucial stuff, but there are a lot of things I would want to recover.

Best regards,

Daniel


Hi!


roth:/dev# pvscan .... PV /dev/hdi1 VG my_volume_group lvm2 [149.05 GB / 0 free] PV /dev/hde1 VG my_volume_group lvm2 [76.69 GB / 0 free] PV /dev/hdg5 VG my_volume_group lvm2 [57.25 GB / 964.00 MB free] Total: 3 [282.99 GB] / in use: 3 [282.99 GB] / in no VG: 0 [0 ]

roth:/dev# vgscan
 Found volume group "my_volume_group" using metadata type lvm2



With pvscan --partial -vvv I found some extra info.


/dev/mapper/my_volume_group-mylv: Added to device cache
/dev/my_volume_group/mylv: Aliased to /dev/mapper/my_volume_group-mylv in device cache (preferred name)
/dev/my_volume_group/mylv: Skipping: Unrecognised LVM device type 254 <---
...
Finding volume group "my_volume_group"
Opened /dev/hde1
Opened /dev/hdi1
/dev/hdi1: lvm2 label detected
/dev/hde1: lvm2 label detected
Opened /dev/hdg5
/dev/hdg5: lvm2 label detected
Read my_volume_group metadata (5) from /dev/hde1 at 4096 size 1341
/dev/hdi1: lvm2 label detected
/dev/hde1: lvm2 label detected
/dev/hdg5: lvm2 label detected
Read my_volume_group metadata (5) from /dev/hdi1 at 4096 size 1341
/dev/hdi1: lvm2 label detected
/dev/hde1: lvm2 label detected
/dev/hdg5: lvm2 label detected
Read my_volume_group metadata (5) from /dev/hdg5 at 4096 size 1341
Found volume group "my_volume_group" using metadata type lvm2



Is this perhaps why I cant mount it? How can I restore? I still am a bit confused with Metadata file saying: pv0 { id = "3Pv4bt-9E47-aDii-mJbB-6OYc-pCFS-7dOBv9" device = "/dev/hdi" # Hint only }

when I pv(re)created hdi1

Regards,
Daniel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]