[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] pvscan fails



Hi

after a system crash my system can't find it's LVM volumes:

System:
- SuSE 7.3 with last 7.3 patches, own Kernel Update to 2.4.26
- was running for some longer time with SuSE lvm-1.0.0.2_rc2-6
  (vgscan --help -> LVM 1.0.1-rc2 - 30/08/2001 (IOP 10))
- I've updated LVM to LVM 1.0.8 - 17/11/2003 (IOP 10)
  in the hope to fix the problem

vgscan dies with a Segmentation fault

odie:~/LVM/1.0.8/tools # vgscan -v    
vgscan -- removing "/etc/lvmtab" and "/etc/lvmtab.d"
vgscan -- creating empty "/etc/lvmtab" and "/etc/lvmtab.d"
vgscan -- reading all physical volumes (this may take a while...)
vgscan -- scanning for all active volume group(s) first
vgscan -- reading data of volume group "DATAVG" from physical volume(s)
Segmentation fault
odie:~/LVM/1.0.8/tools # 

pvscan finds the volumes of the VG

odie:~/LVM/1.0.8/tools # pvscan
pvscan -- reading all physical volumes (this may take a while...)
pvscan -- inactive PV "/dev/hdc1"  is associated to unknown VG "DATAVG"
(run vgscan)
pvscan -- inactive PV "/dev/hdd1"  is associated to unknown VG "DATAVG"
(run vgscan)
pvscan -- inactive PV "/dev/hdb1"  is associated to unknown VG "DATAVG"
(run vgscan)
pvscan -- total: 3 [306.23 GB] / in use: 3 [306.23 GB] / in no VG: 0 [0]

odie:~/LVM/1.0.8/tools # 

Running vgscan -dv results in

...
<1> vg_read_with_pv_and_lv -- AFTER lv_read_all_lv; vg_this->pv_cur: 3 
vg_this->pv_max: 255  ret: 0
<1> vg_read_with_pv_and_lv -- BEFORE for PE
<1> vg_read_with_pv_and_lv -- AFTER for PE
<1> vg_read_with_pv_and_lv -- BEFORE for LV
<1> vg_read_with_pv_and_lv -- vg_this->lv[0]->lv_allocated_le: 32500
Segmentation fault

(copied the last few lines - didn't want to send 72k debug output)

Is there any chance to fix this without loosing the data on the disks?


Frank

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]