[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] How to extend a root LVM volume?



I'm trying to extend a root LVM. I'm using LVM2 on FC2. Here is what I've tried:

I ran lvextend when the system was booted normally and the volumes were mounted. This worked as expected and lvdisplay properly shows the new larger size.

Then I booted into the FC2 rescue CD and instructed it to NOT search for and mount Fedora installations. I then ran:
# resize2fs /dev/Volume00/LogVol00
I don't have the specific error, but it basically says that the specified volume doesn't exist. Indeed if I look in /dev, my volume group and volumes are nowhere to be found.


At that point I tried:
# lvm
lvm> vgscan
After only about 1 second, it responds that no volumes are found.

I also tried rebooting from the CD and letting it mount my installations. In this case, the volume and volume groups are properly discovered and mounted. However, if I try to unmount the volume, it always responds with "device busy".

Is this a problem with how the FC2 rescue disk scans for volumes? Any help would be appreciated.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]