[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM Problems when moving data off a PV

I've got a volume group (vg2) that spans 3 partitions on two disks;
hdb1, hdb5, hdc.  hdb1 and hdb5 are the only partitions on disk hdb.

Disk hdb is failing and I've got an identical replacement from Maxtor,
so I stuck the new disk in and tried to follow the instructions on the
LVM howto for removing a disk. 

I've successfully transfered hdb5 to the new disk (hdd) but I got an
error when trying to move hdb1; I can't remember that error now but I am
assuming that there may be damage to that part of the disk as the disk
is failing.

After trying a few things I found on the lvm lists and other places and
I'm now at a stage where a vgscan reports

vgscan -- only found 4253 of 4267 LEs for LV /dev/vg2/storage (0) 
vgscan -- ERROR "vg_read_with_pv_and_lv(): allocated LE of LV" can't get
data of volume group "vg2" from physical volume(s)

I tried a couple of things from very old posts I found on the lvm
mailing list including compiling LVM2 from cvs so I could do a vgreduce
--removemissing but that didn't work (I assume because they are lvm1) 

Can anyone tell me what might be wrong, and more importantly how I can
get the volume group back up. 

I am assuming that as the data is spread across 3 disks if I can't
recover from this error then I will have lost everything on them. 

Unfortunately I don't have a backup because I have nothing large enough
to backup the data in the volume group. 


Nick Gushlow.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]