[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] lvm 1 unable to boot


I have a machine with the following partition structure:

/dev/sda1 /boot (ext3)
/dev/sda2 swap
/dev/sda3 LVM

The LVM (1.03/rh9) contains one PV and this has Volume00 in it which
contains lvs for slash, usr, var, /usr/local and so on...

I rebooted the machine for the first time in ages (same kernel
configuration as the last reboot and no changes - or very few).

The machine won't reboot - it panics because of a message (something)

vgscan found inactive "Volume00"
Error 28 Unable to make /etc/lvmtab.d/Volume00/Volume00.tmp
vg_cfgbackup.c line 273

It then gives an error about pivot_root panic with the error unable to
mount /dev/Volume00/slash mount error 2 
(the same sort of error as if fstab was wrong but it isn't)

Here's what I've tried to fix this:

- boot into rescue mode: lvscan shows all lvs no problem
	checked pvscan, vgscan, lvscan - no problems
	fscked slash - okay
	checked configuration files, fstab, etc.
tried a reboot - another panic
- rescue mode again
	delete /etc/lvmtab and /etc/lvmtab.d
reboot - panic
- rescue: reinstall lvm rpm and kernel
- make a new initrd.img
...plus lots of other things that were probably irrelevant.

The machine *still* panics when booted normally but works fine in rescue
mode, with a chrooted slash.

Any ideas?


Geoff Dolman
JDRF/WT Diabetes and Inflammation Laboratory
Cambridge Institute for Medical Research
University of Cambridge

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]