[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM2 + pvmove + no warning


I just tried to move some volume group of mine from one harddisk to
another, using pvmove, just like I did before when using LVM1, only to
discover that pvmove is actually not supported.
The very big problem I have with this is that pvmove did not tell me
*ANYTHING* at all about it not being supported. It happily started
creating a snapshot on the first lv in the vg (being my /home partition
of all things), spewed a boatload of errors about ioctl cmd 9 not being
supported and b0rked out leaving the complete volume group inaccessible.
After a hard reset the volume group did not even mount, and the vg
appeared to be somewhat borked as well. Luckily, I was able to recover
all the data on the volume group.
But, what bugs me very much after this episode: I discovered posts on a
mailing list dated as far back as 11/02 stating that pvmove was 'not yet
implemented' in LVM2. But, why is there not a *SINGLE* warning included
in the pvmove tool about this?? Especially as I do not seem to be the
first one who got caught with this! It seems to me that, at the very
least, a warning should be included. An even better solution would be to
just not enable and/or install pvmove by default, because it isn't even

Kind regards,

Michel Wilson.

(please cc any replies directly to me, as I'm not subscribed to the
Michel Wilson     michel crondor net
PGP key ID        0xD2CB4B7E

Attachment: pgp00011.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]