[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] restoring lvm volume group



All,


I created a volume group "m73304raid_vg1" with 2 physical volumes "/dev/sda"
and "/dev/sdc" .
I then created 2 logical volumes "/dev/m73304raid_vg1/raid_lv1" occupying
/dev/sda and 
 "/dev/m73304raid_vg1/raid_lv2" occupying /dev/sdc.    formated the volumes
with linux "ext3" file 
system and stored some data on the volumes.

One of the scsi devices where getting errors and hung up the system.  Now I
can't get the system
to mount the volumes:

I am running RedHat Enterprise Linux 3.0 (u3), but created the volumes under
(u1). I upgraded
to u3 to solve scsi issue, but started having problems with lvm under u1.


vgscan only found 0 of 4095 LEs for LV /dev/m73304raid_vg1/raid_lv2 ,  and
there are no reports of 
                      dev/m73304raid_vg1/raid_lv1.
          vgscan ERROR "vg_read_with_pv_and_lv():  allocated LE of LV  can't
get data of volume group 
          "m73304raid_vg1" from physical volumes(s)

vgchange -a y /dev/m73304raid_vg1 ,   reoprts
         volume group "m73304rai_vg1" does not exist.

pvscan  reports
        inactive PV "dev/sda" is assoceated with unknown VG "m73304raid_vg1"
(run vgscan)
        inactive PV "dev/sdc" is assoceated with unknown VG "m73304raid_vg1"
(run vgscan)

vgcfgrestore -n m73304raid_vg1 -v  -l  -l --test 
       shows all the right information about the original VG, LV and PV but 

vgcfgrestore -n m73304raid_vg1 -v  /dev/sda /dev/sdc          
     reports:  -- usage information
                   please enter physical volume name

can anybody help me recover my data?
         


___________________________________________
Azed Jean-Pierre, Ph.D.
Ocean Products Division  - Code N93
Naval Oceanographic Office
Stennis Space Center, MS 39522
(228) 689-8021
___________________________________________


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]