[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] lvm volume corruption



I am having some trouble installing gentoo on a striped lvm setup. The
architecture is AMD64 and it is Gentoo 2005.0.

The system specs are: 
Athlon 64 3500+ 
MSI K8T Neo2-FIR 
1 gig ddr400 ram 
FastTrak 150 sx4-m 
3x Maxtor 120 gig sata drives 
Geforce 6800 
Soundblaster Audigy 
DVD-RW DL 
Mouse + Keyboard 

The 3 sata 120 gig hard drives are attached to the FastTrak 150 sx4-m raid
card. There is no array configured. I was gonna use hardware (apparently not
possible with this card) or software raid 5 but ive heard of some problems
with reliability. This setup was previously running Windows XP with no
stability issues. 

The disk structure as reported by fdisk looks like this: 
/dev/sda 
/dev/sda1 100 mbs /boot 
/dev/sda2 2.5 gigs swap 
/dev/sda3 2 gigs / 
/dev/sda4 extended 
/dev/sda5 112 gigs approx Linux LVM 

/dev/sdb 
/dev/sdb1 117 gigs approx Linux LVM 

/dev/sdac 
*this disk was gonna primarily be used for back up only purposes by doing
snapshots 

After creating the lvm volumes according to the gentoo lvm guide (i am
striping across the first 2 drives using 4k blocks) and formatting them with
ext3, I encountered an error while installing some packages where one volume
suddenly became read only. I ran e2fsck on the resulting volume devices and
found several inode errors including imagic flag, dtime and linked list
corruption errors. I tried multiple times to create these stripes, format
them with ext3, and then run e2fsck without success. I recreated the volumes
without striping and noticed no problems with e2fsck. Id like to use
striping and don't see what i am doing wrong. Can lvm stripe across
different sized partitions and if so, how are the stripes determined once
one partition is used up?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]