[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Problems with df and lvm



I just installed FC3 on a brand new 80gb hard drive. Up until this point I have been using Redhat 7.3, so this whole thing with LVM is pretty new to me.
 
I had the drive partitioned into three parts (on top of the boot and swap partition):
 
/ 20gb
/dstar 10gb
/home 45gb
 
However, when I use df, I get this:
 
dracon:/home/infoteq# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      20158332   5611396  13522936  30% /
When I use lvdsiplay, I get this:
 
dracon:/home/infoteq# lvdisplay
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol00
  VG Name                VolGroup00
  LV UUID                Ud4qo5-Ysba-HETb-mm0u-ntvi-oEI0-kzreZ7
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                19.53 GB
  Current LE             625
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:0
  
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol02
  VG Name                VolGroup00
  LV UUID                d2CYD9-8fOX-fVd5-VFdF-7kuL-7P7U-Ed9ERM
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                9.78 GB
  Current LE             313
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:1
  
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol03
  VG Name                VolGroup00
  LV UUID                7rHvJC-5SNh-HO7I-acKM-3n0B-teFy-XlVZMa
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                44.06 GB
  Current LE             1410
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:2
  
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol01
  VG Name                VolGroup00
  LV UUID                AZ0FwK-KL1j-CAPS-emtT-3Uzt-Xlhi-I3t127
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                1.00 GB
  Current LE             32
  Segments               1
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:3
My fstab shows this:
 
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/VolGroup00/LogVol02 /dstar                  ext3    defaults        1 2
/dev/VolGroup00/LogVol03 /home                   ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
 
So the drives are there, and I have put data on them, but for some reason, it won't display it on df. I've looked all over for some sort of clue as to why this happened, but have come up empty handed.
 
Is there some way to fix df so that it will display the information correctly? If not, is there some way I can avoid causing this problem in the future?
 
Thanks for your time,
 
-Jay

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]