[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Re: Can't mount after crash



Alasdair G Kergon wrote:

On Sun, Dec 12, 2004 at 12:19:42AM +0100, Daniel Roth wrote:


My lvm-system crashed a day ago and I was really lost in how to do.


You don't say how you actually first discovered something had gone wrong, or give any clues about what might have led up to the problem causing it.

Your message doesn't show any LVM problems.

Did something scribble over your disks?
Have you tried mounting with alternative superblocks?


Ok. I did an upgrade of my Debian system.apt-get update && apt-get upgrade *. lvm version got
updated as well. Afterwards I did a reboot to put in some extra hw (memory). After reboot I couldn't
mount my volume at all. No VG was found et.c. I tried to vgcfgrestore without any halp whatsoever
It only said that the pv could not be found or equiv so I restored them with the pvcreate line below,
which worked fine on the volumes and a vg and lvm was set up appropriately. Still unmountable,
Still unable to fsck.ext2 it with some diffrent superblocks.


I'd be happy to give any specific information you might need to find out any way to restore, since
I have run completely out of ideas. If the file system only is "wrapped" into the lvm I'd like to
find a tool which can scan disks and recognize superblocks, since I only have tried the 3-4 first
I could count up to.


I found the metadatafile and could with
pvcreate --uuid ... --restorefile ... .... /hdg5,



You should only use those if you've lost a disk or accidentally overwritten the start of one and vgcfgrestore isn't working.

Alasdair



"or accidentally overwritten the start of one" is maybe just what has happened.



Daniel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]