[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] hardware snapshots: uuid issue



Hi,

Unfortunately I do not get to the filesystem level. There is XFS on them 
all right, but it's LVM2 that is not handling the uuid change as 
expected...so there is no LV to mount.

Gilles

--
RESTENA - DNS-LU
6, rue Coudenhove-Kalergi
L-1359 Luxembourg
tel: (+352) 424409
fax: (+352) 422473



I use XFS when I am going to use snapshots.

It has a mount option to ignore the UUID conflict.


On Thu, 6 Jan 2005 17:14:34 +0100, gilles massen restena lu
<gilles massen restena lu> wrote:
> Hello everyone,
> 
> Some time ago I had a problem accessing a hardware snapshot of an LVM2
> partition. The reason: different physical volumes having the same UUIDs.
> The advice I was given was to use the "pvchange --uuid" command, but I'm
> unable to use that command whitout making the PV unusable.
> 
> What happens is this: the PV is there, it is found, but  becomes an
> "unknown" device. pvdisplay and pvdisplay <device> disagree somewhat,
> andit seems as if the old uuid is sticking around. vgscan or pvscan are 
of
> no use.
> 
> Now I have no idea what else to try... BTW, I also failed having two
> instances of LVM by setting LVM_SYSTEM_DIR: the second instance still
> finds the PVs of the first even...even with the appropriate filters.
> 
> Any ideas how to continue here? For the time beeing the hardware 
snapshots
> are not very useful...
 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]