[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Segfault in lvcreate?



I used an old version from a build I cvs updated from
earlier this year:

LVM2/tools/CVS/Entries: /lvcreate.c/1.91/Thu Apr  7 12:39:43 2005//

and was able to create my lv.  my current version is:

/lvcreate.c/1.96/Fri Jun  3 19:48:19 2005//



debugging to a small degree, it looked like the problem
was in LVM2/lib/metadata/lv_manip.c::_setup_alloced_segment

and the parameters to alloc_lv_segment, but I'm too busy at the moment to
track it further.  if I get a chance, I'll try to debug further
and submit a fix.

-dan



On 5, Jul, 2005, Dan B. Phung declared:

> am I doing something wrong? 
> 
> blade01:phung # pvdisplay
>   --- Physical volume ---
>   PV Name               /dev/sdb
>   VG Name               lil_cheesy1
>   PV Size               68.32 GB / not usable 0
>   Allocatable           yes
>   PE Size (KByte)       4096
>   Total PE              17491
>   Free PE               17491
>   Allocated PE          0
>   PV UUID               LXHvR8-IrQ0-SGV9-wkL2-a0bE-GsQG-vLG6Mg
> 
> blade01:phung #  lvcreate  -L68G -n lil_cheesy1_lv lil_cheesy1
> Segmentation fault
> 
> 
> -dan
> 
> _______________________________________________
> linux-lvm mailing list
> linux-lvm redhat com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/
> 

-- 
email:  phung cs columbia edu
www:    http://www.cs.columbia.edu/~phung
phone:  646-775-6090
office: CS Dept. 520, 1214 Amsterdam Ave., MC 0401, New York, NY 10027


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]