[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Removing PE from LV fails



Hello list,

sorry for my mail bombing this day, I was really upset about my troubles. I did actually kill the process by kill -9, and as far as I can see, there have been no problems.

Now I'd like to ask a question about my main problem:

I can't remove one PE from the VG. I'm running LVM 1.0.8-2 on RHEL 3. This is what the shell gives me:

   # pvmove /dev/sde
   pvmove -- moving physical extents in active volume group "express_vg"
   pvmove -- WARNING: if you lose power during the move you may need
           to restore your LVM metadata from backup!
   pvmove -- do you want to continue? [y/n] y
   Segmentation fault


I can't see the Distribution as well:

   # pvdisplay -v /dev/sde
   --- Physical volume ---
   PV Name               /dev/sde
   VG Name               express_vg
   PV Size               1.37 TB [2938208256 secs] / NOT usable 64.25
   MB [LVM: 215 KB]
   PV#                   6
   PV Status             available
   Allocatable           NO
   Cur LV                1
   PE Size (KByte)       65536
   Total PE              22415
   Free PE               19530
   Allocated PE          2885
   PV UUID               JtrSU1-82Om-HjJC-5rvC-aVwB-Cc5y-WsRbHQ

      --- Distribution of physical volume ---
      LV Name                   LE of LV  PE for LV
   Segmentation fault



Even with the -d option, there is not more information regarding the Distribution of physical volume. I it helps I can put the -d and -vv outputs on a webserver.

What I did not try yet is booting off a gentoo live-CD and using LVM2 to remove the PE. Is that a good decision?

Thank you for any help. Best regards,
Sebastian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]