[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] HELP: system unbootable after failed pvmove (unrecognized segment type mirror)


I booted the Gentoo 2006.0 Minimial Install CD.  I ran 'lvm vgscan' and it recognized 'london'.  When I ran 'lvm lvs', it showed the pvmove LV.  I entered 'pvmove --abort'.  When I entered 'lvm lvs' again, the pvmove LV was gone.

It seems wrong that the LVM tools would support attempting to do a pvmove when snapshot support is compiled out.

Joe Harvell <joeharvell yahoo com> wrote:
Please help.
Yesterday I executed 'pvmove /dev/sda5 /dev/sda3' to move data within volume group 'london.'  It failed as paraphrased below:
$ pvmove /dev/sda5 /dev/sda3
Unrecognised segment type mirror
Unable to active mirror logical volume
Execute pvmove --abort
Unrecognised segment type mirror
Unrecognised segement type mirror
The pvmove command hung and never completed.  I executed the 'lvs' command from another window and it hung.  I executed the 'pvmove --abort' command from another window and it hung, too.
The system was up and running and working fine, as long as I didn't enter an LVM command.
pvmove has worked for me before on this system.  I think what changed is that I recompiled it without mirrors support because I was tired of seeing the "Unrecognized segment type mirror" all the time.  I think this broke pvmove, because when I read the documentation about what it does, it says it creates a mirror LV or something like that.
When I rebooted, the failure happend in my initrd.  My / and /usr are in LVs in VG london.  When I did the lvm vgscan, it complains with the following two lines several times:
Unrecognised segment type mirror
Couldn't read all logical volumes for volume group london
At the end it says 'Volume group "london" not found'
By the way, it did find one of my other volume groups.
The initrd LVM version info is as follows:
LVM version: 2.02.05 (2006-04-21)
Library version: 1.02.07 (2006-05-11)
Drvier version: 4.5.0
The kernel is 2.6.16.
In the system the initrd is trying to boot, the LVM version info should be the same.  It is definitely either the same or newer.  As I stated earlier, the lvm tools in the system were compiled without mirror support.  I think the same is true of the version in the initrd, but it might not be the case.
Okay, so what do I do???
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com _______________________________________________
linux-lvm mailing list
linux-lvm redhat com
read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]