[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] pvmove of lvs while filesystems mounted not supported?!?



Redhat support is telling me (see quote below) that pvmove is not supported when there are mounted
filesystems on top of the lvs that are being moved. Can this be true? Everyother lvm that I have
worked with allows this. I am currently experiencing device mapper hangs when I run pvmove while
there are filesystems mounted even if there is no processes using the filesystems. 
Is this supposed to work? If so, has anyone had similar issues? Any help would be appreciated? 

Thanks,
Ed
ed quillen net

server info:

<Z>sys66# uname -a
Linux sys66.kelly.com 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28 EST 2006 x86_64 x86_64 x86_64
GNU/Linux
<Z>sys66# rpm -qa | egrep 'lvm|device-map'
device-mapper-1.02.02-3.0.RHEL4
lvm2-2.02.01-1.3.RHEL4
system-config-lvm-1.0.16-1.0
device-mapper-1.02.02-3.0.RHEL4


redhat response:

Hello,
The pvmove command attempts to move all of the data off the pv for a vg. Since the pvmove cannot
lock the vg from putting information back on the pv this operation does not work. A pvmove is
normally done when a the vgs\lvs connected to it are not mounted. Once the pvmove is completed you
would start removing the space allocated to the vg. This operation is not supported while the
assocated filesystems are mounted.

Thank You


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]