[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Lost logical volume?



Peter Smith <peter smith utsouthwestern edu> wrote:
Tom+Dale wrote:

> Greetings.
> I am hoping that some LVM experts can help me out. I have a partial
> volume group that spans two drives and I would like to recover the
> logical volume that was on it so that the data is accessible. The
> group (VolGroup00) was originally set up spanning part of one drive
> and all of the other drive (both IDE). The group was entirely applied
> to a single logical volume (LogVol00) to be mounted as /video. This
> was working until I tried to make some changes and I fear that I may
> have lost the data. I cannot seem to resolve this problem anywhere
> else. I have spent almost two weeks searching for clues and asking for
> help in other forums, but I do not yet have a solution. I hope to
> provide all of the useful information below.
> *History*
> I am relatively new to linux, having built my own PVR using Fedora and
> MythTV during the last year. I have relied heavily upon HowTos and
> guides written by other users. One of the guides that I followed
> instructed me to set up XFS using LVM which would allow me to span
> multiple hard disks. Recently, I added a new SATA drive to my MythTV
> system. The new drive was designated as /dev/sda. It appeared to add
> into the existing volume group without any problem, though I did not
> get it to the point where the space was accessible. I planned to
> further research that problem; however, the new hard drive failed
> before I got that far. Here’s what things looked like after removing
> the drive:
> [root[at]mythserver ~]# pvdisplay
> Couldn't find device with uuid 'fxlccO-4li0-nmyD-9avZ-Vc60-GGWX-jUhqOv'.
> Couldn't find device with uuid 'fxlccO-4li0-nmyD-9avZ-Vc60-GGWX-jUhqOv'.
> --- Physical volume ---
> PV Name /dev/hda5
> VG Name VolGroup00
> PV Size 66.12 GB / not usable 0
> Allocatable yes (but full)
> PE Size (KByte) 4096
> Total PE 16926
> Free PE 0
> Allocated PE 16926
> PV UUID 317l2C-oay1-TWFG-5NTX-XJS3-vLal-Xh5bBL
>
> --- Physical volume ---
> PV Name /dev/hdb
> VG Name VolGroup00
> PV Size 298.09 GB / not usable 0
> Allocatable yes (but full)
> PE Size (KByte) 4096
> Total PE 76311
> Free PE 0
> Allocated PE 76311
> PV UUID nfLxS1-0u3t-5Zr9-57iu-1oZe-Bkkd-75SERQ
>
> --- Physical volume ---
> PV Name unknown device
> VG Name VolGroup00
> PV Size 232.88 GB / not usable 0
> Allocatable yes
> PE Size (KByte) 4096
> Total PE 59617
> Free PE 225
> Allocated PE 59392
> PV UUID fxlccO-4li0-nmyD-9avZ-Vc60-GGWX-jUhqOv
>
>
Tom. I'm sorry that not too many people have looked into this with you.

First, what were the results of the "vgreduce --removemissing
VolGroup00" command? I'm generating a theory here. That VolGroup00 had a
single LV, LogVol00, and the disks /dev/hda5 and /dev/hdb. Then--I'm
guessing here--you did a "pvcreate /dev/sda" .. And followed that with a
"vgextend VolGroup00 /dev/sda" .. Then perhaps did you do a "lvextend -l
/dev/VolGroup00 /dev/sda"? After that, at some point,
/dev/sda went dead. Am I close? Could you recount to us what steps you
took to "expand" the VG? I realize you may have been asleep, but this
data is crucial. When I do any LVM work I typically record all my input
and output in a text editor and save it or print it out for safety..

So, the questions are:
1) Was that LV the ONLY LV in the VG?
2) You did try to expand the LV to include /dev/sda?
3) Did you use any GUI to do this? Or did you rely on the command line?

Peter

Peter,
 
Thank you for your reply...I wish I'd seen it _before_ complaining about no responses.  My apologies to you and the other list members! 
 
In retrospect, I agree that documenting our LVM intrepid adventure would have been smart.  I confess that I cannot tell you precisely what commands we gave to add the new (later failed) hard drive.  However, your effort at retracing our steps sounds remarkably familiar.  I would say that it is essentially correct if not exactly.
 
I'm not sure what the results of the "vgreduce --removemissing VolGroup00" command were other than that it appeared to me as though it was successful.  Would that be logged somewhere?
 
1. Yes, initially VolGroup00 spanned /dev/hda5 and /dev/hdb.  LogVol00 was the only logical volume in VolGroup00, and it was using the entire space of VolGroup00.
 
2. Yes, we tried to expand the LV to include /dev/sda but I think we were doing something wrong because we couldn't seem to get the MythTV app to see more space available (see below).
 
3. No, no GUI tools.  We were strictly using the command line in an xterm session.  This is FC4 with xfce desktop (in case that matters).
 
I think you are right:  we added the drive using "pvcreate /dev/sda" and then we did "vgextend VolGroup00 /dev/sda" (those look right from what I remember...coming up on three weeks ago, now).  So expanding the VG would have been accomplished at this point, right?  I believe we got to that point successfully.  Now I'm not sure how we tried to expand the LV, but I'm pretty sure that it did not work because we couldn't see the new space available from the MythTV app (it still reported the original volume size for total disk space as if we'd made no addition).
 
So we may have tried "lvextend -l" with parameters or perhaps we never figured that part out.  You know, we were drinking lots of Diet Coke while searching the net and reading man pages, re-reading the LVM HowTo, and trying different things...timidly.  I'm certain that we could see from pvdisplay & vgdisplay that we were close but not done yet.  We quit for the night and I discovered the physical disk problem the next afternoon.
 
Two final comments:
 
A) I can't get to the box right now, as I am travelling this week.  But I sincerely appreciate your assistance and I'll be able to access it after Saturday 02Sep06.
 
B) I remember seeing some archives and backups in an LVM directory not on the logical volume.  Are these key to recovering the LV?  It looks like people have posted the contents of these files in the past (they look like programming code to me).  I wasn't sure what to post or if they would be helpful.
 
Sorry about being lengthy, but I want to provide a complete picture.
 
-Tom-


Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]