[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] errors using mkinitrd: cannot stat lvm2/vgwrapper



The stock 2.4 kernel has LVM1 support only (not LVM2).  I'm not sure
about your RedHat kernel, but Gentoo has a 2.4 kernel with LVM2
backported.  If your volumes are LVM2 format then you can only read them
if you have LVM2 support in your kernel.  Even if you created the
volumes in an LVM2 system, they may still be LVM1 format.

If you do have LVM2 support in your kernel, you need to install the lvm2
tools and the device_mapper library  Then mkinitrd should find what it's
looking for.  Although it's strange that my LVM2 tools don't have any
file named lvm2 or vgwrapper.  Maybe these are added by RedHat and part
of the RedHat LVM2 package.

If your kernel only supports LVM1 and your volumes are in LVM1 format,
you need to generate an LVM1 based initrd.  Maybe mkinitrd has options
for this?

George Nychis wrote:
> Hi,
>
> I am having trouble booting a 2.4.32 kernel with fedora core 3, I can
> successfully boot the partition with 2.6.9
>
> I built the 2.4.32 kernel with lvm support built in, and as a module,
> and get the following errors when trying to mkinitrd:
>
> cannot stat lvm2: No such file or directory
> cannot stat /sbin/vgwrapper: No such file or directory
>
> The initrd still gets created though, but I think these errors are the
> sources of my problems.  /sbin/vgwrapper, as it says, does not exist
>
> Any ideas how to fix these errors?
>
> Thanks!
> George
>
> _______________________________________________
> linux-lvm mailing list
> linux-lvm redhat com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/
>
>   


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]