[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM1 - "VGDA in kernel and lvmtab are NOT consistent" error following lvm operations



Hello,

I've been using LVM (1.08), which comes by default with RedHat AS3update5, for over a year now and am consistently running into a problem.  I hope there are still some LVM version 1 users out there who have some knowledge about this!!

After a reboot, LVM typically functions as expected, however, oftentimes, after some LVM operations, I get the following sequence:

[root mucrrp10 vb]# vgdisplay
vgdisplay -- ERROR: VGDA in kernel and lvmtab are NOT consistent; please run vgscan

[root mucrrp10 vb]# vgscan
vgscan -- reading all physical volumes (this may take a while...)
vgscan -- found active volume group "prdxptux"
vgscan -- found exported volume group "prdtuxPV_EXP"
vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
vgscan -- WARNING: This program does not do a VGDA backup of your volume groups

[root mucrrp10 vb]# vgdisplay
vgdisplay -- ERROR: VGDA in kernel and lvmtab are NOT consistent; please run vgscan

This is troublesome because it makes it difficult to reliably use certain LVM commands and trust their results.  I need to minimize reboots as much as possible.

Any help in understanding the cause of this problem, and how to resolve it, or avoid it, are greatly appreciated!!

Here is some version info about the system and software (I can provide more information if needed):

[root mucrrp10 vb]# cat /etc/redhat-release
 Red Hat Enterprise Linux AS release 3 (Taroon Update 5)
 [root mucrrp10 vb]# uname -a
 Linux mucrrp10 2.4.21-32.ELsmp #1 SMP Fri Apr 15 21:17:59 EDT 2005 i686 i686 i386 GNU/Linux
 [root mucrrp10 vb]# rpm -qa|grep lvm
 lvm-1.0.8-12.2
 
Thanks in advance for any assistance.
Regards,
David





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]