[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM and Device Mapper



Hello,

I've setup multipath with multipath-tools and I guess everything is OK
there. However, I can't get lvm to recognize the multipath'ed devices:

# dmsetup ls
3600508b40010130d00006000011c0000p1     (253, 4)
system-lv03     (253, 2)
system-lv01     (253, 1)
system-lv00     (253, 0)
dm-3p2  (253, 7)
dm-3p1  (253, 6)

cabtagdb01:~ # fdisk -l /dev/dm-3

Disk /dev/dm-3: 53.6 GB, 53687091200 bytes
64 heads, 32 sectors/track, 51200 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

    Device Boot      Start         End      Blocks   Id  System
/dev/dm-3p1               1           1        1008   83  Linux
/dev/dm-3p2               2       51200    52427776   8e  Linux LVM
cabtagdb01:~ # fdisk -l /dev/mapper/3600508b40010130d00006000011c0000

Disk /dev/mapper/3600508b40010130d00006000011c0000: 53.6 GB, 53687091200 bytes
64 heads, 32 sectors/track, 51200 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

                                        Device Boot      Start
End      Blocks   Id  System
/dev/mapper/3600508b40010130d00006000011c0000p1               1
  1        1008   83  Linux
/dev/mapper/3600508b40010130d00006000011c0000p2               2
51200    52427776   8e  Linux LVM


# pvcreate /dev/dm-3p2
 Device /dev/dm-3p2 not found.

# pvcreate /dev/mapper/3600508b40010130d00006000011c0000p2
 Device /dev/mapper/3600508b40010130d00006000011c0000p2 not found.

Does anyone have any guess on what the problem might be? I seem to be
one-step from getting this solved and I am going through these
hassles.

Thank you,
Pierre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]