[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Re: need help booting from SATA in 2.4.32 / LVM



On Wed, May 17, 2006 at 01:30:18PM -0400, George Nychis wrote:
> 
> 
> Lennart Sorensen wrote:
> > On Wed, May 17, 2006 at 09:40:52AM -0400, George Nychis wrote:
> >> Because it does......
> >>
> >> on bootup the *same* exact drive in 2.4.32 shows up as /dev/hda
> >>
> >> It has the exact same volume information as my drive that shows up in
> >> 2.6.9 as /dev/sda
> > 
> > Yes I do remember a few sata controllers had some support in 2.4, which
> > was dropped from 2.6 early on when libata came in.
> > 
> > It is very unlikely you will ever see that again in the future.
> > 
> > Len Sorensen
> > 
> 
> I see... well I am finally getting it to boot, i did not have initrd
> support built into the 2.4.32 kernel, but now i'm getting LVM errors:

Cool, that's fine !

> Scanning logical volumes
>    /bin/vgscan.lvm1: execvp failed: No such file or directory
> ERROR: /bin/vgscan exited abnormally!
> Activating logical volumes
>    /bin/vgchange.lvm1: execvp failed: No such file or directory
> ERROR: /bin/vgchange exited abnormally!
> 
> I know nothing about LVM so... i'm pretty clueless for now

It's pretty clear to me that /bin/vgscan is a wrapper to either vgscan.lvm1
or vgscan.lvm2 depending on what it supported in the kernel. 2.4 only
supports LVM1 in mainline. There are patches to support LVM2 on 2.4,
but to be honnest, I'm not sure about the exhaustive list. All I know
is that you have to start with the device mapper :

   http://w.ods.org/linux/kernel/2.4/lkup/device-mapper.html

I hope it will help you
Willy


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]