[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Re: alternate link / multi-pathing



On Sun, May 28, 2006 at 02:50:24AM +0100, C'est Pierre wrote:
Nevermind about my previous question! I just made my way into this
page: http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/s390-multi-install-guide/s1-s390info-raid.html
and have setup the multipathing nicely.

actually the device-mapper-multipath would a better approach than
md-multipath

However, I went into the second node (this is 2 nodes failover cluster
environment) and I noticed that the vg and the md0 appeared there
there automatically! is this normal? is there anything I should do?

it is not normal
it should not happen

if you insist in using md multipath, ensure raid autodetect won't pick
it up.
i.e. disable damned autodetect on kernel command line or
change the partition type to something different than 'Linux Raid'

then you'll have to ensure that your distribution  init scripts do not
automatically start it.
best way is omitting this set entries from /etc/mdadm.conf
and putting it somewhere else, then invoking
"mdadm -Asc /some/where/else/mdadm.conf" in your cluster script

if you use device-mapper-multipath (which might also solve the issue in
your next post :)
there is no problem if multipath finds the devices on the failover node,
but you must prevent lvm from activating the vg

to do this either add cluster locking or use tags, as explained in the doc/tagging.txt files in the lvm distribution

Regards,
L.


--
Luca Berra -- bluca comedia it
       Communication Media & Services S.r.l.
/"\
\ /     ASCII RIBBON CAMPAIGN
 X        AGAINST HTML MAIL
/ \


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]