[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Trouble creating snapshot device



Hello,

We are in trouble creating snapshot devices on fedora-core 4... Kernel
version: 2.6.16-1.2111_FC4smp. We have created new RPM's using the
development SRPMS (device-mapper-1.02.07-1.0 & lvm2-2.02.06-1.2.1). The
same trouble occurs with stock device-mapper & lvm2 RPM's!

Sometimes the snapshot device is created succesfully but most times is
fails... The script:

ophelia.han.nl:~# lvs
  LV      VG   Attr   LSize   Origin Snap%  Move Log Copy%
  cache   vg   -wi-ao   1.00G
  home    vg   -wi-ao 500.00M
  log     vg   -wi-ao 500.00M
  postfix vg   -wi-ao  10.00G
  tmp     vg   -wi-ao 100.00M
  usr     vg   -wi-ao 800.00M
  var     vg   -wi-ao 200.00M
ophelia.han.nl:~# lvcreate -s -n test -L 100M /dev/vg/postfix
  LV vg/test in use: not deactivating
  Couldn't deactivate new snapshot.
ophelia.han.nl:~# lvs
  LV      VG   Attr   LSize   Origin Snap%  Move Log Copy%
  cache   vg   -wi-ao   1.00G
  home    vg   -wi-ao 500.00M
  log     vg   -wi-ao 500.00M
  postfix vg   -wi-ao  10.00G
  test    vg   -wi-a- 100.00M
  tmp     vg   -wi-ao 100.00M
  usr     vg   -wi-ao 800.00M
  var     vg   -wi-ao 200.00M
ophelia.han.nl:~# mount /dev/vg/test /1
mount: you must specify the filesystem type
ophelia.han.nl:~# lvremove /dev/vg/test
Do you really want to remove active logical volume "test"? [y/n]: y
  Logical volume "test" successfully removed
ophelia.han.nl:~# lvcreate -s -n test -L 100M /dev/vg/postfix
  Logical volume "test" created
ophelia.han.nl:~# mount /dev/vg/test /1
ophelia.han.nl:~# ls /1
active  bounce  corrupt  defer  deferred  flush  hold  incoming  lost
+found  maildrop  pid  private  public  saved  trace
ophelia.han.nl:~# umount /1
ophelia.han.nl:~# lvremove /dev/vg/test
Do you really want to remove active logical volume "test"? [y/n]: y
  Logical volume "test" successfully removed
ophelia.han.nl:~# lvcreate -s -n test -L 100M /dev/vg/postfix
  LV vg/test in use: not deactivating
  Couldn't deactivate new snapshot.
ophelia.han.nl:~# mount /dev/vg/test /1
mount: you must specify the filesystem type
ophelia.han.nl:~# lvremove /dev/vg/test
Do you really want to remove active logical volume "test"? [y/n]: y
  Logical volume "test" successfully removed
ophelia.han.nl:~# lvcreate -s -n test -L 100M /dev/vg/postfix
  LV vg/test in use: not deactivating
  Couldn't deactivate new snapshot.
ophelia.han.nl:~# lvremove /dev/vg/test
Do you really want to remove active logical volume "test"? [y/n]: y
  Logical volume "test" successfully removed

Anyone any idea?


Kind regards,

Patrick

----------------------------------------------------------------------
| Patrick Honing (Patrick Honing han nl)
| ICT Developer
| Intelligent Network & Middleware Services (INMS)
| Service Bedrijf SU ICT
| Hogeschool van Arnhem en Nijmegen (http://www.han.nl)
| Tel.: +31-26-3691522 Fax: +31-26-3691510




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]