[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] LV open but not mounted ?

Hello Paddy,

Only making a wild guess here, but perhaps you had it mounted with "mount -o loop vg-foo/lv-bar /mnt"? This command will create a loopback device which will then be mounted. The 'dirty part' is that 'umount' will NOT reverse this process. It will unmount but not remove the automatically created loopback device. This stays attached to the LV which remains opened.

Kind regards,

Erik de Bruijn

http://www.BudgetDedicated.com | Tel. +31 13 4690625 | Fax. +31 84 2248796 | Adres: Adelaarshorst 9 | Zipcode NL-5042 XE

paddy wrote:
On Mon, Oct 09, 2006 at 04:49:35PM -0500, Jonathan E Brassow wrote:
Hmmm, I can see where it might be 'active', but if it's not in use, it shouldn't be open.

It is open. lvchange -an says LV in use: not removing

but I'm drawing a blank on finding anything that is actually using it.

I'm kinda hoping someone can throw some light on what 'open' is here.

Some sub-lvs are marked as 'open', because they are used by the main LV (such is the case with mirroring and snapshots).

no mirrors, no snapshots :-(

I have looked through /etc/lvm/backups and can't see anything odd.

Have you tried 'lsof <path to LV>' ?

yup, tried lsof, tried fuser, there is no nfs, got nowhere.
It's one of those things where I fully expect to have to say "d'oh sorry!",
but until I can get deeper into it I am really stumped.

On Oct 9, 2006, at 1:58 PM, paddy wrote:

I just noticed that I have a system where an LV appears to be open
(as given by lvs), but I can't see it mounted anywhere, or opened
by any process.

Any insights, suggestions, explanations, etc gratefully received :-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]