[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Q: Online resizing ext3 FS

Goswin von Brederlow schrieb:
Tomasz Chmielewski <mangoo wpkg org> writes:


Yes, I tried to online resize a similar filesystem (600 MB to 1.2 TB)
and it didn't work.

At some point, resize2fs would just exit with errors.
I tried to do it several times before I figured out what's missing;
sometimes, I interrupted the process with ctrl+c. No data loss

To do an online ext3 resize, the filesystem needs a "resize_inode"
feature. You can check the features with dumpe2fs:

So was that what you were missing or did some other error occur?

I tried to resize an fs without resize_inode and it just plain told me
and abrted.

It was working for some time (15 or 30 minutes?), the fs grew a couple of gigabytes, and then it exited with an error. At first I thought it's because the fs might need fsck, but after I did fsck, it didn't help - next online tries didn't increase the fs anymore.

Tomasz Chmielewski

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]