[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] mirrored LV + cmirror problem



I disconnected the lun from both nodes and it worked, the LV went to linear. Thanks for the help!

One more question, what do you think about this testing scenario: Two- nodes cluster, each node has a local disk which is exported via GNBD to itself and to the other one. I build a cluster-mirrored LV on the GNBD devices, then I kill one of the nodes. In this case, the cmirror should work well? The LV will go to linear mode?

Attila

On Feb 18, 2008, at 7:30 PM, Jonathan Brassow wrote:

That's the problem. (C)LVM does not currently have a way to handle the disappearance of a device from just one machine... it expects a similar view of devices from all machines in a cluster. "Locking" on the second node fails because it doesn't know what to do with the disk that it sees (that has been removed from the node suffering the failure).

There is someone working handling orphaned/removed devices that reappear (which would be similar to this case), but I'm not sure if they've taken this scenario into account. I'll let him know about this.

brassow

On Feb 18, 2008, at 10:48 AM, Lajkó Attila wrote:

Yes, I disconnected the lun via the Vtrak GUI from one of the nodes (el4).

Attila

On Feb 18, 2008, at 5:08 PM, Jonathan Brassow wrote:

How are you performing the failures? It looks like just one machine is loosing its connection to the device, while the other machines links remain in place.

brassow




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]