[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] [IMPORTANT]LVM+iSCSI issue..Local Disk disappeared..



Hi himanshu,

himanshu padmanabhi schrieb:
> We configured it as
> *
> Case 1
> 
> *pv1= localdisk1    pv2 =localdisk2
> 
> Vg1= pv1,pv2
> 
> created lv1 of size =pv1size + pv2size
> 
> Deleted lv1,
>  
> removed pv2,
> 
> vg is getting displayed properly in vgs command
> 
> *
> Case 2
> 
> *pv1= localdisk1    pv2 =remotedisk2(iscsi disk)
> 
> Vg1= pv1,pv2
> 
> created lv1 of size =pv1size + pv2size
> 
> Deleted lv1,
> 
> logout from iscsi target
> 
> vg is not getting displayed properly in vgs command
In case 1 you just physically removed the pv2? And vgdisplay shows you
the error message of the missing pv in the vg? Or you removed the pv
from the vg, vgdisplay showing you that the vg is ok?

In case 2 you just log the iscsi target out, which is the same as just
pulling the cable off, and vgdisplay doesn't show you, that the vg is
damaged, cause the pv2 is missing?

If you want to remove the pv2 from the vg without getting it in error
state, you have to remove the pv from the vg before iscsi-logout.

Anyways, it would be quite helpfull to cut-n-past the output of
vgdisplay into your mails instead of telling us, that it's not
displaying properly ;-).

Ciao
Klaus
-- 
Mit freundlichen GrĂ¼ssen / best regards

Klaus Strebel, Dipl.-Inform. (FH), mailto:klaus strebel gmx net

/"\
\ /     ASCII RIBBON CAMPAIGN
 X        AGAINST HTML MAIL
/ \


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]