[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] read only filesystem on LVM device after changing path in SAN



Hi,

I hope I am right here, if not, please let me know where would be a better 
place to ask. I have observed a problem on LVM based partitions when I change 
the paths through the SAN. 

Here my setup: I have a 3TB partition, coming from a SAN IBM DS4700, the same 
but smaller, for the operating system partition. Both presented to a xen 
host. On the data partition I have a LVM configured. There are four paths 
through the SAN for each of the disks. The host type on the DS4700 for the 
server is configured as LNXCLVMWARE, which as for the documentation should be 
the right one.

# multipath -ll
Pilot-Project-VMs (3600a0b800048b31000000ffd4a10fd7e) dm-1 IBM,1814      FAStT
[size=280G][features=1 queue_if_no_path][hwhandler=1 rdac][rw]
\_ round-robin 0 [prio=2][enabled]
 \_ 4:0:1:0 sdf 8:80  [active][ghost]
 \_ 3:0:1:0 sdg 8:96  [active][ghost]
\_ round-robin 0 [prio=12][active]
 \_ 3:0:0:0 sdb 8:16  [active][ready]
 \_ 4:0:0:0 sdc 8:32  [active][ready]
Pilot-Project-Data (3600a0b800048b31000000fbe49f962e5) dm-3 IBM,1814      
FAStT
[size=3.0T][features=1 queue_if_no_path][hwhandler=1 rdac][rw]
\_ round-robin 0 [prio=2][enabled]
 \_ 4:0:1:1 sdh 8:112 [active][ghost]
 \_ 3:0:1:1 sdi 8:128 [active][ghost]
\_ round-robin 0 [prio=12][enabled]
 \_ 3:0:0:1 sdd 8:48  [active][ready]
 \_ 4:0:0:1 sde 8:64  [active][ready]

When I run a dd copy job, creating a file on the Operating system partition, 
e.g. dd if=7dev/zero of=/data/file then everything seems to be fine. I change 
the path through the SAN via the DS4700 management GUI, and the dd job keeps 
running as expected, so no problem without LVM.
When I do the same on the LVM partition, then after some seconds, after I 
switch the preferred path through the SAN, then the LVM partiton becomes 
read-only, and the dd job dies. Then on the dom0, a 
fdisk -l /dev/mapper/3TB-Partion still shows output, but 
fdisk -l /dev/mapper/3TB--Partion-1 on the LVM device, just shows nothing.
When I then shutdown the xen host, and do a:
/etc/init.d/boot.lvm restart
then fdisk -l /dev/mapper/3TB--Partion-1 on the LVM device, produces output 
again. However, the startup of the xen domU may still spit out errors, and 
the mounting of the device in the domU may still not work. I had to reboot 
the dom0 physical host to get the partition back in a working state. 

I do not have any kind of special configuration for the LVM device, I created 
it via yast2. 

Is there anything what I can do to prevent the LVM based partition to become 
read-only when a path in the SAN switches? 
If I need to provide more information let me know whats needed.

kind regards
Sebastian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]