[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] read only filesystem on LVM device after changing path in SAN

On Mon, 2009-06-08 at 17:48 +0200, Sebastian Reitenbach wrote:
> When I run a dd copy job, creating a file on the Operating system partition, 
> e.g. dd if=7dev/zero of=/data/file then everything seems to be fine. I change 
> the path through the SAN via the DS4700 management GUI, and the dd job keeps 
> running as expected, so no problem without LVM.
> When I do the same on the LVM partition, then after some seconds, after I 
> switch the preferred path through the SAN, then the LVM partiton becomes 
> read-only, and the dd job dies. Then on the dom0, a 
> fdisk -l /dev/mapper/3TB-Partion still shows output, but 
> fdisk -l /dev/mapper/3TB--Partion-1 on the LVM device, just shows nothing.
> When I then shutdown the xen host, and do a:
> /etc/init.d/boot.lvm restart
> then fdisk -l /dev/mapper/3TB--Partion-1 on the LVM device, produces output 
> again. However, the startup of the xen domU may still spit out errors, and 
> the mounting of the device in the domU may still not work. I had to reboot 
> the dom0 physical host to get the partition back in a working state. 
> I do not have any kind of special configuration for the LVM device, I created 
> it via yast2. 
> Is there anything what I can do to prevent the LVM based partition to become 
> read-only when a path in the SAN switches? 
> If I need to provide more information let me know whats needed.

Have you configured filtering in lvm.conf to exclude the path devices?
It's worth checking that LVM is using the multipath devices to create
the mappings for the LV that's having the problem and not the underlying
SCSI disk paths.

You don't mention the kernel and lvm2 versions you're using although the
behavior you describe doesn't ring any bells with regards to already
known bugs/problems.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]