[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] pvremove won't work



Hi All, 

I have a LVM over 3 partitions (3 separate disks) and one of them is failing so I need to remove it from the group. I moved the content to the rest of the disks (pvmove) and now pvdisplay shows:

root neriak:~# pvdisplay
  --- Physical volume ---
  PV Name               /dev/sdb1
  VG Name               storage
  PV Size               186.31 GB / not usable 4.00 MB
  Allocatable           yes (but full)
  PE Size (KByte)       4096
  Total PE              47694
  Free PE               0
  Allocated PE          47694
  PV UUID               QUmigK-SCow-nMKo-NEcC-cOQY-bAO9-3k6g9K

  --- Physical volume ---
  PV Name               /dev/sdc1
  VG Name               storage
  PV Size               149.05 GB / not usable 1.31 MB
  Allocatable           yes
  PE Size (KByte)       4096
  Total PE              38156
  Free PE               19483
  Allocated PE          18673
  PV UUID               idHUfs-rd5i-fVf7-UzE0-YGJT-X1k4-mrp3be

  "/dev/sda4" is a new physical volume of "200.87 GB"
  --- NEW Physical volume ---
  PV Name               /dev/sda4
  VG Name
  PV Size               200.87 GB
  Allocatable           NO
  PE Size (KByte)       0
  Total PE              0
  Free PE               0
  Allocated PE          0
  PV UUID               TNsOa7-2Ibb-IW9i-C1s5-1NI9-L5e3-WlKnSH


However, I can't remove /dev/sda4 (the partition on the failing disk) from the group: 

root neriak:~# pvremove /dev/sda4
  Can't open /dev/sda4 exclusively - not removing. Mounted filesystem?

I don't see it mounted anywhere. The LVM is also unmounted. Any ideas of what I might be doing wrong ? I am running LVM 2.02.39 on Ubuntu 9.04 64bit

Thanks in advance,
Stefan



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]